Another Trailer Light Problem - Nissan Titan Forum
User Tag List

 
Thread Tools Display Modes
#1 Old 10-29-2012, 10:15 PM
Forestteck
Shift_Newbie
 
Join Date: Jul 2011
Location: North Central Florida
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Another Trailer Light Problem

I found out recently that my left side trailer lights are out (right side ok) and I have no running lights at all.(both sides). I tested connector on the hitch so I know its the truck and not the trailer. Any ideas? Thanks

2004 Nissan Titan 4x4 LE Crew Cab with Big Tow.
Forestteck is offline  
Sponsored Links
Advertisement
 
#2 Old 10-30-2012, 04:27 PM
Forestteck
Shift_Newbie
 
Join Date: Jul 2011
Location: North Central Florida
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Update: I found two blown 10 amp fuses. One under the dash and one under the hood in the square looking fuse box. The one under the hood is marked "Trailer Tow". When I changed the fuses, I got all of my turn signals back but blew the 10 amp fuse under the hood again. I am thinking now that my "Trailer Tow #2" relay has gone out and blows this fuse. I have no running lights and no power to the trailer brakes. What do you think? Does this sound right?

2004 Nissan Titan 4x4 LE Crew Cab with Big Tow.
Forestteck is offline  
#3 Old 11-01-2012, 10:09 PM
Wyatt
Shift_Newbie
 
Wyatt's Avatar
 
Join Date: Aug 2012
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yeah....I'd find a U Haul Trailer/Hitch Installation Center. They find that GREMLIN!!
Wyatt is offline  
#4 Old 11-30-2012, 02:44 PM
challenger3x2
Shift_Enthusiast
 
challenger3x2's Avatar
 
Join Date: Oct 2006
Location: Northwest, NJ
Posts: 278
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
If the trailer your towing is older or has any kind of rusting issues your most likely loosing a good ground while traveling. When trailer lights are working are any of the bulbs flickering or weaker. If you work on trailer your self you could try running a common ground wire to each light and then back to trailer connector.
Trailer brake ground wires should also be checked and changed to the common ground wire from lights.
Rusting trailer frames and poor contact between body mounts between trailer body and frame will cause this condition.
At least thats what I have found.

06 Titan LE,4x4,Steel Leather,Red Alert,Big Tow,Factory Step Rails,Brush Gaurd,Floor Mat,Bed Extender.. Add On's- In Channel Window Vent,Rear Spoiler mounted on RollBak Retractable bed cover... 2 Deg Timing Mod.. AirRaid TBS... NISMO Cold Air Intake.. BullyDog GT III and FlowMaster cat back dual exhaust.. Drilled/slotted rotors and Evolution pads front and rear.. JBA headers, rear sway bar.
challenger3x2 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

  Similar Threads
Thread Thread Starter Forum Replies Last Post
trailer light problem sledgie Technical Discussion 20 10-23-2008 11:52 PM
trailer light problems rtitan05 Technical Discussion 9 06-06-2007 07:59 PM
Trailer Lights Problem. Rossi Technical Discussion 2 05-17-2007 09:13 AM
OEM Trailer Hitch and aftermarket exhausts... problem? GalaxyTitan22 Performance Mods 5 03-23-2006 10:28 AM
Trailer Brake Problem? Nique General Discussion 11 10-03-2005 08:55 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off