Black transmission fluid less then 10k on my truck, wow - Nissan Titan Forum
 
Thread Tools Display Modes
post #1 of 5 Old 02-04-2013, 02:05 PM Thread Starter
Tonyv46
Shift_lurker
 
Join Date: Dec 2012
Location: Canada, manitoba
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Black transmission fluid less then 10k on my truck, wow

so as i said i had problems with my dealer
and i decided to take it on myself to change the fluid in the transmission
i used dexron3 temp till i get some amsoil

when i started the process i wasnt prepared to see what i did
it was solid black fluid looked like engine oil and smelt like burnt clutch

the pressure line goin to the rad cooler was the fualt it had come off(clip wasnt in right location) i drove like this not knowing

and i lost about 3-4quarts of fluid

and didnt have a problem till it started slipping
and wouldnt engage into gear till i let it cool down

should the dealer be held responible for not checking this line i have just slightly over 10k on my truck now

and my concern is that the friction plates are toast and the steelies between the plates are scored even blued

this should be covered under warrenty right ?
and 33s and 3inch leveling kit shouldnt do anything to void this ?
Tonyv46 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-05-2013, 10:10 PM
WhiteDuke
Shift_lurker
 
Join Date: Jul 2012
Location: Austin, Tx
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My stock tires are pretty close to 33's. I have no real world experience with warranty issues like this, but I can't see it causing thAt type of premature failure. I hope it is covered for you. Please let me know what is said
WhiteDuke is offline  
post #3 of 5 Old 02-05-2013, 11:38 PM
HRTKD
Shift_Obsessed
 
HRTKD's Avatar
 
Join Date: Feb 2007
Location: Denver Area
Posts: 4,391
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Should be covered. But I wouldn't be using dexron3. Put actual Nissan fluid in there before you take it back or they might say the dexron caused the problem. I run AMSoil in my Titan's transmission without any issues.

«Granite '07 LE Crew Cab, 4x4, Big Tow, Off-Road, Side Curtain Airbags, Sunroof»
«ClearBra, Leer 100XQ, MM SI9500 Winch, Volant PowerCore, 18" Magnaflow, AMSoil in everything»
«SAW Coilovers and rear shocks, PRG upper control arms and shackles, Berk Technology B-Pipes»
Club Titan Rosetta Stone
Jim
HRTKD is offline  
post #4 of 5 Old 02-06-2013, 11:57 PM
Misfit482
Shift_Enthusiast
 
Misfit482's Avatar
 
Join Date: May 2009
Location: milwaukee area
Posts: 443
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
I've heard of some dealers being real strict about stuff as simple as a leveling kit or larger tires. Hasn't been an issue with me for warranty stuff. Like HRTKD said, put some Nissan tranny fluid in there before you take it in. Is the Dexron you used J-matic approved? I forget which years used a different fluid type.

'07 CC 4X4 banks ram air w/ tb screen removed, banks monster exhaust, prg minilift, PRG UCA's, 5100's mid perch, sway bar removed, 5125's, DK shackles, Brake motive brakes, headlight mod w/ JB switcbacks, Legit 55w 6000 hid's (lows and highs), modded tail lights, street scene grille shell, xd diesel 20x10 w/ terra grapplers, pinch weld mod, axle vent mod, BW pocket flares, PD'd stuff, BL step rails, SM designs bezel kit
Misfit482 is offline  
post #5 of 5 Old 02-10-2013, 09:45 AM
WhiteDuke
Shift_lurker
 
Join Date: Jul 2012
Location: Austin, Tx
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I'm taking mine back to the dealer tomorrow.friday it got stuck in 4 low for about 45 minutes. I tried everything. Even unplugged the battery for a while. Finally, I turned it on and put it in gear and never engaged. I put it in park and heard a shaft grind to a stop. It was not neat. Mine is a 2012. I hope trans is okay. But I definetly need my transfer case to work.
WhiteDuke is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

  Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission fluid help!! whitetitan01 Scheduled or Preventive Maintenance 15 01-30-2009 09:38 AM
transmission fluid mark General Discussion 0 10-08-2007 10:43 PM
Transmission fluid KING TITAN General Discussion 9 05-08-2007 10:11 AM
how to read the transmission fluid? alohaarg Scheduled or Preventive Maintenance 14 03-15-2007 04:20 PM
transmission fluid leak Magnum General Discussion 1 12-30-2006 01:50 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off