Anyone find a solution to the cruise control issue? - Page 2 - Nissan Titan Forum
Reply
 
Thread Tools Display Modes
post #11 of 16 Old 12-16-2008, 09:55 AM Thread Starter
fropleyquark
Shift_lurker
 
Join Date: Nov 2006
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
So the stealership took a look and said it was the switch on the brake pedal (after I already tested it good). I went ahead and blew $40 on a new switch. Of course that didnt fix the problem. So.... now Im at a loss. Anyone else got any ideas?
fropleyquark is offline  
Sponsored Links
Advertisement
 
post #12 of 16 Old 12-16-2008, 12:43 PM Thread Starter
fropleyquark
Shift_lurker
 
Join Date: Nov 2006
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
update: I just went out and reset my ecu. Seems to have fixed it. Took it out for a run and so far so good. Even cut the engine on and off a few times. No more blinking set light and the cruise works! Hopefully this will have fixed it. So, to anyone else having this issue, before you go throwing money and parts at it, try resetting the ecu.
fropleyquark is offline  
post #13 of 16 Old 12-17-2008, 07:56 AM Thread Starter
fropleyquark
Shift_lurker
 
Join Date: Nov 2006
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ok, im not letting this thread die! So, cruise stopped working again. Man, I was so pissed. I really thought resetting the ecu fixed it. Well atleast this tells me that its something with the ecu (?) Anyone else got any ideas?
fropleyquark is offline  
 
post #14 of 16 Old 04-04-2014, 08:04 PM
Boucherman
Shift_lurker
 
Boucherman's Avatar
 
Join Date: Jun 2013
Location: Northern Michigan near Traverse City
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I know this is a really old thread, but here goes. I had lots of trouble with my cruise set light blinking. I read LOTS of threads on it from this and other sources. I even reset my tpms and ecu many times. After lots of reading and observations I came to the conclusion that I needed a new cruise control switch. Sometimes the cruise would not respond to the switch to turn on or off. It is too much work for me to remove it with the airbag and all the stuff in the steering wheel. ANYWAY I fixed it. It has been good for over a year now. It cost me nothing. here is how I did it.

I figured that I had nothing to lose. I turned it on and watched it blink set...set...set...set...You know. Then I took my fist and beat the crap out of the back of the steering wheel behind the switch. I was driving on the freeway at the time. It stopped blinking. It worked!! It has been good ever since. Possibly the switch has some contact areas that get a little corroded with time, and the pounding cleaned the contacts a bit. ??? It sure is nice to have a functioning cruise controll again.

If any of you try this and it works for you too, could ya post a reply? I'd like to know if my beating on it actually is what fixed it.

Thanks
Boucherman is offline  
post #15 of 16 Old 07-09-2014, 10:28 AM
jongordo8
Shift_Newbie
 
Join Date: Nov 2007
Location: Lewisville, TX
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to jongordo8
Guys I have been dealing with this blinking issue for years and am just beyond frustrated. I checked the switch at the brake pedal and it is good. I then pulled several fuses in the right side of the dash and it worked for about an hour or 2 on a recent trip, then started blinking again. Any ideas what I could try next to see if I can resolve it? I am driving 2k miles in the truck and would love to have use of cruise control.
jongordo8 is offline  
post #16 of 16 Old 12-15-2016, 12:33 PM
Jackolope56
Shift_lurker
 
Join Date: Dec 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Try turning steering wheel to different positions to see if ascd switch operates (cruise lamp lights)while pressing "on" button.
Jackolope56 is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

  Similar Threads
Thread Thread Starter Forum Replies Last Post
Axle vent issue and solution CJ3FLYR Do it yourself, Tech Tips 54 09-09-2009 04:45 PM
Finally found front end issue SeaTitan Suspension 49 05-18-2009 01:22 PM
Cruise Control Issue Warp09 General Discussion 4 05-27-2008 09:24 PM
FULL DETAILS! Fall 2007 issue, Nissan Sport NissanSportSarah General Discussion 25 09-28-2007 06:45 PM
Alignment = Cruise control? Hazertmed General Discussion 4 12-17-2005 04:24 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off