Loss of power while accelerating. - Page 2 - Nissan Titan Forum
Reply
 
Thread Tools Display Modes
post #11 of 13 Old 12-17-2012, 09:03 AM Thread Starter
Mauro
Shift_lurker
 
Join Date: Oct 2012
Location: Miami, Florida
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Well I did the following things to the truck. Changed the spark plugs, changed the IPDM relay, changed the evap valve and added the filter kit (all nissan), and the last thing I changed was the fuel pump (also nissan, it was only $25 more than the aftermarket). The truck is driving smooth and I feel that it has more power. The code came back but I read somewhere that the are a few more things that could be causing it to go on. One could build up of moisture inside the evap canister, which I did not check before I changed the valve. The other could be a seal that may not be fitting correctly after the fuel pump was replaced. They seem to loose their shape and when you replace the pump they don't fit back exactly right. I will probably take care of this by next week, after the 21st, since the end of the world is near, I don't want to spend more money ;-)
Mauro is offline  
Sponsored Links
Advertisement
 
post #12 of 13 Old 04-13-2015, 06:39 PM
cat2004
Shift_lurker
 
Join Date: Apr 2015
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I have a 2004 titan and would lose power hailing . We changed out the fuel pump and it fixed the problem
cat2004 is offline  
post #13 of 13 Old 04-14-2015, 10:07 AM
Canadian Miner
Shift_Obsessed
 
Canadian Miner's Avatar
 
Join Date: Jun 2006
Location: Kingston Ontario
Posts: 2,158
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
Quote:
Originally Posted by cat2004 View Post
I have a 2004 titan and would lose power hailing . We changed out the fuel pump and it fixed the problem
Yes there is a TSB for low pressure from the fuel pump.

2012 RAM 2500 Crew 4x4 Cummins
H&S, AFE, Zone 6" Lift, BD Steering Brace, Black Rhino Rims, 35" Yokohoma Geolandar, Powerboards, Lorado Cover, Vision-X LED

SOLD - 2005 SE Crew Off-Road Big Tow High Utility
KC Lights, Nissan Brush Guard, PRG Performance Lift, RADFLO, Deaver Packs, 35" Duratracs, 34" AT KOs, Backup Light, Stillen Rad, AT Grounding Kit, MXP Intake, JBA Titanium Ceramic Long Tubes, Cajun Cat'd 2.5" B Pipes, 08 Pipes, Borla Swap, Ultra Quiet, UpRev Tuned, Timbren SES, RC Traction Bars
Canadian Miner is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

  Similar Threads
Thread Thread Starter Forum Replies Last Post
power loss wabulldogger Performance Mods 10 05-03-2009 07:52 PM
Loss of power, maybe? Warp09 Performance Mods 6 02-12-2008 12:05 PM
How much power loss? bulldog General Discussion 1 09-28-2007 05:52 PM
Loss of power... Please help clwfirefghtnstud Performance Mods 18 06-27-2007 08:44 PM
power loss? gradium Performance Mods 9 05-19-2007 08:14 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off