My AC Is not blowing cold air. I have to - Nissan Titan Forum
 
Thread Tools Display Modes
post #1 of 10 Old 06-24-2007, 06:23 AM Thread Starter
zytan
Shift_Enthusiast
 
Join Date: Dec 2006
Location: Turlock CA
Posts: 184
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My AC Is not blowing cold air. I have to

put it to #4 to feel any cold air, could it be that it needs to be charged? Thanks.
zytan is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 06-24-2007, 08:24 AM
Titan4Evah
Shift_Newbie
 
Titan4Evah's Avatar
 
Join Date: Jun 2007
Location: Maryland
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
What year is your truck? Maybe this is your problem?

http://www.clubtitan.org/forums/showthread.php?t=34823

I saw a huge difference when mine got fixed. From what I understand though, it was just a block of 2007's that got recalled.

2007 CC SE 2WD
Red Brawn
Mods:
OEM Foglight Kit w/Stalk||Custom Duals Flowmaster 50 series SUV||S&B GEN 3 CAI||Bully Dog PP - 87 Regular Tune w/ 2* Timing Advance||WOT restriction removed (omg!)||22" Martin Brothers Sharktooth Wheels||305-40-22 Nitto 420s tires
Titan4Evah is offline  
post #3 of 10 Old 06-25-2007, 01:36 AM Thread Starter
zytan
Shift_Enthusiast
 
Join Date: Dec 2006
Location: Turlock CA
Posts: 184
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My truck is a 2004, Thanks for the link man ill give it a try.

Eis
zytan is offline  
 
post #4 of 10 Old 06-25-2007, 01:14 PM
RBsTitan
Shift_Obsessed
 
RBsTitan's Avatar
 
Join Date: Sep 2005
Location: Houston
Posts: 4,160
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mine is an 04 and does similiar things since day one...not always but definately warmer when it does happen. I check the fan a few times and the paper test strip pulls in as a pusher should. So I just dealt with it and raised Rpm.

2004 CC LE 4x2 5360lbs
DYNO: Stock: 275rwhp 331tq (Fram AirHog)MODS: PGM 90mm Throttle Body, Custom PGM Throttle Body Spacer, Custom Throttle Body Intercooler, RBS Custom Ram Air, 170 Thermostat, Volant G1 CAI, Stillen Headers, Custom B-Pipe w/Cats in line, Custom Banks Exhaust, Father of Titan UpRev Tunes, JWT Cams, Detroit TruTrac LSD, N20, lol

UpRev ProTuner and IRC CREW CHIEF "International Racing Club VK56"

13.90 FST beating mustang

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

13.30 @101.79 FST 80shot

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
RBsTitan is offline  
post #5 of 10 Old 06-27-2007, 08:55 PM
shailey
SHIFT_The_Real_Slim_Shailey
Shift_Obsessed
 
shailey's Avatar
 
Join Date: Nov 2005
Location: Cleveland, TN
Posts: 4,757
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Some of the early 04's were found to have cracks in the high pressure hose in one of the bends.
shailey is offline  
post #6 of 10 Old 06-28-2007, 08:53 AM
Imadogman
Shift_lurker
 
Imadogman's Avatar
 
Join Date: Jan 2006
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by zytan
put it to #4 to feel any cold air, could it be that it needs to be charged? Thanks.
Go here and look at the TSB at the bottom of the page...

http://www.nissanhelp.com/Bulletins/Titan/2004/3.htm
Imadogman is offline  
post #7 of 10 Old 06-29-2007, 03:47 PM
electricjohn
Shift_Fanatic
 
Join Date: Mar 2005
Location: Woods Tavern, New Jersey
Posts: 761
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
How long would this (TSB) be covered under warrantee? 3 years/36k, or 5/60?

04 SE, White, CC, 4x4, B.T., Pop w/capt's, Util. Bed package,Splash Guards,Floor Mats. No mods.(none planned except for inchannel vent visors and an 07 exhaust). Gas whore.
electricjohn is offline  
post #8 of 10 Old 06-29-2007, 08:46 PM
shailey
SHIFT_The_Real_Slim_Shailey
Shift_Obsessed
 
shailey's Avatar
 
Join Date: Nov 2005
Location: Cleveland, TN
Posts: 4,757
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
3 yrs/36,000
shailey is offline  
post #9 of 10 Old 06-29-2007, 09:43 PM
Wiskers
Shift_Enthusiast
 
Wiskers's Avatar
 
Join Date: Jul 2005
Location: El Paso, TX
Posts: 497
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to Wiskers
Check the cabin micro filter. Once it's gooped up it will restrict the air flow and a/c temp.

-2005 Nissan TEXAS Titan LE CC 4x2 Smoke with Navigation, DVD Package, Big Tow, RF System, Captain Chairs, Leather Seats, Sunroof, and more.......
MODS: 2.5" Cornfed mini lift, 6000k HID kits for low & fogs, Volant LED tail lights, all factory bulbs have been replaced w/ LED's, Bently style mesh grille, chrome tailgate trim, chrome window seal trim, chrome door moldings, 20% tint, Burtman's smoked 3rd LED brake light, LUND stainless steel bug shield.
FUTURE MODS: APSIS wood dash kit, A.R.E. LSII tonneau cover, and headrest screens
Wiskers is offline  
post #10 of 10 Old 06-15-2015, 10:26 PM
Taz(copeland)
Shift_lurker
 
Join Date: Jun 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have a 04 5.6 Titan and I can not find out y I can't get cold air . Ever since some one hit my Titans front end the front fan stopped working and has no power to it and now it blows hot air even on #4 air . What do u think it is I need help
Taz(copeland) is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

  Similar Threads
Thread Thread Starter Forum Replies Last Post
The Science Behind An Air Intake TheSquid Technical Discussion 17 10-26-2007 11:07 AM
How To - Install Volant Cold Air Intake M4ck Do it yourself, Tech Tips 21 12-03-2006 01:10 AM
Cold Air Intake And Air Horn Spencer Technical Discussion 14 06-08-2006 11:47 AM
Ram Air-Check out OEM air box snorkel under left front fener AquaDios Performance Mods 6 02-03-2006 06:17 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off