Shudders at stops - Nissan Titan Forum
User Tag List

 
Thread Tools Display Modes
#1 Old 01-30-2013, 02:58 PM
biggreen8807
Shift_lurker
 
Join Date: Dec 2012
Location: bossier city louisiana
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exclamation Shudders at stops

hey all im pretty mechanic savy but this has got me puzzled and I have searched and searched and i keep findinf people talking about this issue but i cant find an answer to it so it just started doing this a few days ago when it just sits there in park it idles fine but when it is in gear and brakes are applied it acts like it is bogging down and starts to shudder the rpms drop to roughly 500 help please this is scaring the cr@p out of me it has 94k miles on the clock

2006 galaxy black cc 4x4 offroad
biggreen8807 is offline  
Sponsored Links
Advertisement
 
#2 Old 01-30-2013, 08:56 PM
Misfit482
Shift_Enthusiast
 
Misfit482's Avatar
 
Join Date: May 2009
Location: milwaukee area
Posts: 408
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sounds like the ECU. Call the dealer with your VIN# to see if yours was replaced under the recall. If not, they should still do it.

'07 CC 4X4 banks ram air w/ tb screen removed, banks monster exhaust, prg minilift, PRG UCA's, PRG endlinks, 5100's all around, DK shackles, Brake motive brakes, headlight mod w/ JB switcbacks, Legit 55w 6000 hid's (lows and highs), modded tail lights, street scene grille shell, xd diesel 20x10 w/ terra grapplers, pinch weld mod, axle vent mod, BW pocket flares, PD'd stuff, BL step rails, SM designs bezel kit
Misfit482 is offline  
#3 Old 01-30-2013, 08:59 PM
biggreen8807
Shift_lurker
 
Join Date: Dec 2012
Location: bossier city louisiana
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thabk you ill be sure to do that tomorrow im wanting to statt moding this beast but its just not lettijg me lol its always something little lol

2006 galaxy black cc 4x4 offroad
biggreen8807 is offline  
#4 Old 01-30-2013, 10:59 PM
scr38
Administrator
Shift_Obsessed
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Lake Jackson, TX
Posts: 6,413
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Not the ECU. It is the ECU relay in the IPDM.
scr38 is offline  
#5 Old 01-30-2013, 11:02 PM
biggreen8807
Shift_lurker
 
Join Date: Dec 2012
Location: bossier city louisiana
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
So do i just need a new relay or what do i do to fix it? And again thank yall for yalls quick replies it is greatly appreciated

2006 galaxy black cc 4x4 offroad
biggreen8807 is offline  
#6 Old 01-31-2013, 09:57 AM
scr38
Administrator
Shift_Obsessed
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Lake Jackson, TX
Posts: 6,413
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
There is a recall on the relay. Check with your dealer to see if your vehicle is included in the recall. If so they will replace the rely at no charge.
scr38 is offline  
#7 Old 02-02-2013, 07:28 PM
biggreen8807
Shift_lurker
 
Join Date: Dec 2012
Location: bossier city louisiana
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ok update on the shudder/chugging i went to the dealership and got a new relay for 5.92 installed it you guys could have told me it was a pita to get to lol anyways i even disconnected my battery for a couple of hours just to help reset everything anyways fired it up and let it run for alittle bit pit it in gear and held the brake and sure enough it started shuddering/chugging again

2006 galaxy black cc 4x4 offroad
biggreen8807 is offline  
#8 Old 02-04-2013, 10:32 AM
biggreen8807
Shift_lurker
 
Join Date: Dec 2012
Location: bossier city louisiana
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bump come on guys this is driving me crazy anyone know anything truck has 94k miles

2006 galaxy black cc 4x4 offroad
biggreen8807 is offline  
#9 Old 02-04-2013, 12:26 PM
scr38
Administrator
Shift_Obsessed
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Lake Jackson, TX
Posts: 6,413
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Have you replaced the spark plugs? if not, its about time to do that. Also check the MAF sensor to see if it is dirty. There are several threads here about that process.
You may want to do the idle air process. Again search here for that process.
scr38 is offline  
#10 Old 02-04-2013, 12:41 PM
biggreen8807
Shift_lurker
 
Join Date: Dec 2012
Location: bossier city louisiana
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
no i havent changed the spark plugs yet i was figuring i would do that since i was getting up there in miles and yes i checked the maf and cleaned it but i will search the idle air process thank you for your help ill update when i get everything taken care of i really need a programmer to help read codes and add alittle to it lol

2006 galaxy black cc 4x4 offroad
biggreen8807 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

  Similar Threads
Thread Thread Starter Forum Replies Last Post
Old bump stops BiXLL Suspension 11 07-29-2009 10:35 PM
Bump stops 04TitanGuy Suspension 0 06-24-2009 04:44 PM
WTB: Rear Bump Stops vuaccordla For Sale/For Trade 4 08-14-2008 10:07 PM
bump stops kahunatitan General Discussion 0 12-10-2007 09:43 AM
bump stops? jp4026 General Discussion 10 02-26-2007 08:07 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off