Nissan Titan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey guys, i'm charles from jamaica and i recently bought an 05 Titan. Love the truck but i've been having some probs whenever it gets warm. I've heard alot about u guys and i'm hoping i can get some help cause i'm lost now, i cant seem to figure it out. These are what has been happening:

1. At wide open throttle, when the rpm approaches the redline, it holds the gear and the rpm holds a state of what appears to be a rev limiter in any gear so the pedal would have to be used to shift to the next gear by backing off a little then goin down again.

2. There are instances, which are becoming more often now, where at part throttle the rpm will not pass 3500-4000rpm. There is a sudden power cut, and the engine doesn't respond to any throttle movement until it falls below the mentioned rpm's. It sounds like a 'soft limiter'- almost feels like a fuel cut or something.

Otherwise it drives well under normal driving conditions, the transmission shifts well and there are no waning lamps on, both the 'check engine soon' and 'AT check' lamps drop out after start up. I hope u guys can help me out.
Thanks in advance
Charles
 

·
Registered
Joined
·
3 Posts
Not sure how long ago you posted this, but it sounds like the fuel pump woes to me. I had the same issue at 2000 RPMs when it got warm or shall I say I'm really warm days. It seemed to work fine during the cold temps of winter but it started puking out this spring so I replaced it or should I say I had it replaced cuz it's a real pain in the butt, and it's running excellent now hope this helps...
 
1 - 2 of 2 Posts
Top