Nissan Titan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter #1
So my gf decided to buy an inverter for the accessory outlets next to both front seats, under our stereo unit. I understand the one on the left (drivers side) is connected directly to battery, and the other one isnt.

Well not knowing that she plugged a my laptop to the one isnt connected directly to the battery and now its fried. Fuse i think is blown, any idea which it is or any suggestions towards this problem?!
 

·
Registered
Joined
·
24 Posts
Unless they have moved the fuse box next to the glove box and the passenger door, just take off the compartment door to the fuse box and there is a diagram of all the fuses on the back. Look for the accessory ones and look at each to see if any are blown. From what I remember there aren't that many to look through. I have a 2005 and had to replace that same fuse a while back, took only a couple minutes to find and replace. Hope this helps!
 

·
Premium Member
Joined
·
6,584 Posts
That will be fuse # 7 in the fuse block.
 

Attachments

·
Registered
Joined
·
145 Posts
Discussion Starter #4
Appreciate the info fellas, ill tackle this during the weekend!
 

·
Registered
Joined
·
765 Posts
All outlets on the Titan are fused, some higher than other. An unfused outlet would be a fire hazzard.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #6
Got it fixed thanks! I ended up buyin a whole mess of fuses + fuse checker(?) from autozone for like 20$
 
1 - 6 of 6 Posts
Top