Nissan Titan Forum banner

21 - 34 of 34 Posts

·
Registered
Joined
·
4,160 Posts
Discussion Starter #21
Yep could be a pickle.....

Hey 95W - Thanks.

What puzzles me is the "self diagnosis" ? What, where and how to?

Another thing is that I have not been able to find another part number for the trannys with BT and non BT. Does anyone have the information? I know there are 5 ECU's for the 04's.

Funny thing is that I have no SES codes and had I not tried to use the cruise control I would have not known it didn't work until much later.

I did use Cipher to run some A/T revolutions versus RPM just to see the differences and yes there are some at cruise but I never logged them both before so I do not know what is considered different?

I do know that Cipher logs two different Speed Sensors and they have never been accurate between them...meaning one was off by 2-5mph all speeds. However now the difference is by 5-11mph at various speeds. Problem there is I don't know which two sensors Cipher is taking the reading.
 

·
Registered
Joined
·
254 Posts
lol, you said you liked a challange - figure it out. lol...Just kidding.

In all likelyness, there will defianaly be some differences between the tranny sensor and the wheel sensors. I'd almost bet that the tranny is the same no matter what - 2.94 or 3.36 rearend.

I'm fairly certain that this is where two of the ECUs come in - one for each axle ratio. It's likely smart enough to say - well, this 3 mph difference is ok, but anything over 5 is out.

Of course, this is all my opinion and doesn't mean squat till someone proves or disproves it.

I'd be interested to see exactly what happens if you were to disconnect the tranny speed sensor. The manual says that the TCM (tranny control module) will revert to the speedometer's can reported speed in the event of the tranny's speed sensor failing. It doesn't however say if it will throw any codes or if it will keep the cruise control from working.

I dug through the manual pretty thoroughly and the sensor and TCM are in the pan - no other way around it - dangit.

On the flip side, if you are to disconnect it and the cruise still doesn't work, I may have a solution for you. I don't have all the details worked out yet, but I'm working on them - and I'm close. A vow to secrecy will get you more information via pm as if it does work, this can pave the way for a product to complete the missing link to the rear diff gearing change many other Titaneers will want to do.
 

·
Registered
Joined
·
4,160 Posts
Discussion Starter #23 (Edited)
Tranny's

2004 Tranny options:
4x2, locking, column shift A.T.
4x2, locking, floor shift A.T.
4x2, non-locking, column shift A.T.
4x2, non-locking, floor shift A.T.

4x4, locking, column shift, w/o off road & HD susp pkg A.T.
4x4, locking, column shift, w/off road & HD susp pkg A.T.
4x4, locking, floor shift A.T.
4x4, non-locking, column shift A.T.
4x4, non-locking, floor shift


2005 Trannys:
Presume Same as Above unless corrected.


So my thinking is that it is ECU controlled via maps. Just my guess.


ECU's for 2004:
4x2, w/o Vehicle Dynamic Control; 2.94 ratio
4x2, w/o Vehicle Dynamic Control; 3.36 ratio
4x2, w/Vehicle Dynamic Control (VDC)
4x4, 2.94 ratio Elec Cont Unit
4x4, 3.36 ratio

ECU's for 2005:
w/flex fuel vehicle, 4x2, w/Big Tow pk g, w/brake limit
w/flex fuel vehicle, 4x2, w/Big Tow pk g, w/o brake limit
w/flex fuel vehicle, 4x2, w/o Big Tow pkg; w/brake limit
w/flex fuel vehicle, 4x2, w/o Big Tow pkg; w/o brake limit
w/flex fuel vehicle, 4x4, w/Big Tow pkg
w/flex fuel vehicle, 4x4, w/o Big Tow pkg
w/o flex fuel vehicle; 4x2; w/Big Tow pkg; w/brake limit
w/o flex fuel vehicle; 4x2; w/Big Tow pkg; w/o brake l
w/o flex fuel vehicle; 4x2; w/o Big To w pkg; w/brake l
w/o flex fuel vehicle; 4x2; w/o Big To w pkg; w/o brake
w/o flex fuel vehicle; 4x4, w/Big Tow pkg
w/o flex fuel vehicle; 4x4, w/o Big To w pkg

So anyway tomorrow if the weather is good I'm going to the race track as I cannot use Cipher with time accuracy since it is based upon sensor feedback.

I'd like to hear your idea W95...secret is safe PM welcomed. I'll sign whatever you want me too...LOL

Well fellas the trutrac and the 3.36 is the cats meOW.....purrrrrrr!

Previous 60ft 2.311
New 60ft: 2.185
New 1/4: 14.35
 

·
Registered
Joined
·
4,160 Posts
Discussion Starter #24
TRACK TESTED: 3.36 and TruTrac

Well fellas the trutrac and the 3.36 is the cats meOW.....purrrrrrr!

Previous 60ft 2.311
New 60ft: 2.185
New 1/4: 14.35 - 75shot
 

Attachments

·
Registered
Joined
·
4,160 Posts
Discussion Starter #26
baseballfanz said:
Do you think the 3.36 help you more or the Tru Trac or a combination of both?
Hard to say as I never had the trutrac in the 2.94...but I can tell you there is limited wheel spin now or alteast tonight. So for me Trutrac is working well with gear.
 

·
Registered
Joined
·
4,160 Posts
Discussion Starter #29
Well I've given up trying to find out what's up with the cruise so I made an appointment with the dealer next Wednesday. Keep ya posted on the outcome....promise!
 

·
SHIFT_Mr. Quick Answers
Joined
·
11,110 Posts
RBsTitan said:
Well I've given up trying to find out what's up with the cruise so I made an appointment with the dealer next Wednesday. Keep ya posted on the outcome....promise!
I was trying to find the thread but can't seems to locate it. Don't remember which forum it was on:D but there is one member who had the exact same problem with his cruise control, he's stock no mod what so ever to his truck.
 

·
Registered
Joined
·
4,160 Posts
Discussion Starter #31

·
Registered
Joined
·
254 Posts
RB, I'm anxious to hear what they have to say. I'm betting there will be a code saying that there is too much variance between the Tranny speed sensor and the wheels speed sensors.

If that's the case, I'm thinking Nissan will have no clue as to where to go next - other than putting in your OEM rear.

If that's the case, your next best bet will be disconnecting the tranny speed sensor in the pan. The refilling and trying it out. Hopefully, you won't get a code saying - no sensor thus no cruise.

If that's the case, I do believe I've got the solution but I'm still working on how to reliably and easily get a set of wires into/out of the pan.
 

·
Registered
Joined
·
4,160 Posts
Discussion Starter #33 (Edited)
Dealer Update:

Ok took the truck into the dealer today. Just got a call back saying that the only fix there is for the cruise issue is to replace teh ECU. However the catch is to replace the ECU with a 2004 4x2 BT no VDC.

They did say that the ECU could not compensate for the 8mph difference it is reading from the sensors. So for those of you wanting to go 4x4 with higher ratio you will lose your cruise control unless you can get big ars tires underneath. The good news is that the truck runs fine like it is just with out cruise control.

So until someone comes out with some electronics tricks we are kinda of hosed.

Update 2:

After talking to the tech during pickup he explained that he tried to send the correct infromation to my ECU for the rear end I have nopw and the NATS would not take the program change. He did say that he was not 100% that it would work. So for $60 I learned what I already suspected.
 
21 - 34 of 34 Posts
Top