Nissan Titan Forum banner
1 - 4 of 4 Posts

·
Registered
2006 Armada LE
Joined
·
5 Posts
Discussion Starter · #1 ·
Any ideas on what to do if horn chirp portion fails during IPDM test? Ohm test reveals continuity from relay base H1 to horn connector. No voltage at relay base during test from IPDM circuit. Changed ecm relay to new style with diode.

Everything else passes test except horn during IPDM test mode. No functions of horn, power lock, window, lights, hvac clutch, blower, and wipers during normal mode. Ignition switch or IPDM issue?

Help.
 

·
Registered
2006 Armada LE
Joined
·
5 Posts
Discussion Starter · #2 ·
Horn works when jumpered. Relay base coil shows continuity to ground as well as common contact. Removed clock spring to alleviate the short to ground. With 15I horn fuse removed and H1 horn relay still shows short to ground but when removed the clock spring it lifted the upstream side of fuse short to ground. Hoping my IPDM does not have any issues either. The parts are $650 for clock spring and $750 for IPDM. A ECM is only $350 plug and play. This is cost prohibitive and not well engineered in my estimation. If the parts were say a 100 apiece then yeah would be too easy but as it stands I have 120 hours and over $2500 in a 2006 Armada to get it back to specs.

Fault 1- Problem-horn does not work in auto active test on ipdm or alarm key fob or steering wheel button. Works on jumper. No voltage at relay base but at fuse. Short to ground on fuse side and relay base coil and common contact side.
IPDM passes all tests except initial horn chirp

Removed clock spring.

Fault 2- lights
red Brake indicator on
VDC off indicator on
ABS indicator on
Slip indicator on

Fault 3- rear suspension sags
LL inoperative
 

·
Registered
2006 Armada LE
Joined
·
5 Posts
Discussion Starter · #3 ·
I threw everything but the kitchen sink at this thing after careful troubleshooting protocols. I was told it is a faulty BCM ergo trip to the dealer on Monday. I drained the rear end grease and serviced it while waiting for reasonable solutions and found a coolant leak under rear right side above spare tire so in a way I guess that was serendipitous for me to avoid a slow spray of ELC on the road. I am going to the junkyard once to see if I can find an 06 BCM the one I found is an 07 and it doesn't work though it plugged right up. I miss my diesels. Anyone know how to re-set the ABS, slip, and vdc off with brake indication? I bled the brakes and filled it back up like recommended.

Horn inoperative in any mode. Power locks, windows, hvac, front fan, condenser fan, no seat adjustment, Everything but horn works on IPDM auto active test. Cannot reset the ECU. Cannot re-set the brake, ABS, slip, vdc off lights.
Rear leveling system inoperative. Air bag light flashing now after changing the clock spring. No codes. I think there is a short in the system.
 

·
Registered
2006 Armada LE
Joined
·
5 Posts
Discussion Starter · #4 ·
Dropped off at dealer today anyone have a figure you'd like to guess for estimate?

Horn inoperative all modes
Brake, ABS, Slip, VDC off, Airbag flashing and TPMS flashing
rear coolant line leaking underneath behind rr tire
 
1 - 4 of 4 Posts
Top