Nissan Titan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all new here I hope someone can help me. I have some electrial problems here is what they are and what I have checked. My gauges are jumping when I turn on the key after a about 5 seconds they start working fine, I have no power to my temperature controls the ac fan in the truck blows on high only, I have no ding from the ignition key or from the headlights, My obd2 port is not working. The truck starts and runs and transmission shifts fine. What I have done installed new battery no help checked all fuses none blow checked all connections all seem good. I Have not done anything like install radio it just started doing this. Thanks to anyone that can help me with this.

Gene
 

·
Registered
Joined
·
6 Posts
Hello all new here I hope someone can help me. I have some electrial problems here is what they are and what I have checked. My gauges are jumping when I turn on the key after a about 5 seconds they start working fine, I have no power to my temperature controls the ac fan in the truck blows on high only, I have no ding from the ignition key or from the headlights, My obd2 port is not working. The truck starts and runs and transmission shifts fine. What I have done installed new battery no help checked all fuses none blow checked all connections all seem good. I Have not done anything like install radio it just started doing this. Thanks to anyone that can help me with this.

Gene
Sounds like a problem with the IPDM (intelligent power distribution module). Under hood, battery side, there are 2 fuse boxes. One in rear has a row of 6 square black modules. 1st on left is for IPDM. Last on right is fog lights. You can try swapping these around to see if that helps. If so you can get a new one and they are cheap. If that doesn't work, it could be the IPDM itself. I'm not an expert just the owner of a 2006 that I have done a lot of work on that I couldn't have done without the help of this forum. If what I have read is correct, the IPDM is the panel that holds all those relays and fuses. Someone with more knowledge about this please feel free to correct or add to this. Hope this helps and gets you started on a solution.
 
1 - 2 of 2 Posts
Top