Nissan Titan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
When I exit my truck I smell antifreeze and the odor is strong. I check the reservoir and when running at normal temp it's about 1"-2" below the max mark.
I went out of town with my son and I parked my truck on a clean surface and placed cardboard underneath for 2 days. I don't see any leaks anywhere. The carpet in my truck isn't wet but I normally only smell it standing outside the truck not on the inside.

Any ideas?

Thanks
 

·
Registered
Joined
·
6 Posts
When I exit my truck I smell antifreeze and the odor is strong. I check the reservoir and when running at normal temp it's about 1"-2" below the max mark.
I went out of town with my son and I parked my truck on a clean surface and placed cardboard underneath for 2 days. I don't see any leaks anywhere. The carpet in my truck isn't wet but I normally only smell it standing outside the truck not on the inside.

Any ideas?

Thanks
Have you pressure checked the system? I can think of 3 things off the top of my head. Radiator cap losing pressure, overflow cap for same reason and the seal around the radiator and bottom tank. Also, check your trans fluid for discoloration from the cooling element inside the bottom radiator tank. (Far fetched, but seen it before)
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
Nah. Took it to the dealer and they kept it for a few hours and didn’t find anything. I looked in the shop and I know the mechanic checked it because it looked like half the engine was sitting on the bench and floor. I had to wait almost an hour for him to put it all back. He said it’s most likely vapors coming from the overflow jug because it has a vent. Pressure checked and checked all the connections. Nothing found. Truck doesn’t overheat so I’m just gonna drive it
 
1 - 3 of 3 Posts
Top