Nissan Titan Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
lol...not kidding. I'd normally think it was the Blower or VBC, but this one is new to me so I figured I'd ask the experts here...

AC and Heat don't work. BUT if I put it on HIGH only and then touch the door lock actuator, the Blower goes for about 5 seconds blowing hot or cold, whichever is selected. After 5 seconds it stops. It'll allow me to keep doing this but not trying to lock the door every 5 seconds I want AC in AZ!!
Also, the overdrive and manual shift option do not work.

I just got the truck and the previous owner was not very knowledgable but said it may be a problem with the alarm or stereo wiring.

Any ideas?
 

·
Premium Member
Joined
·
6,584 Posts
This could be a nightmare since no one knows what has been modified.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
FIXED !!!

Believe it or not this was the variable blower control module.

Lesson...any issue with the variable speed control is probably the VBCM even if it only works when you lock the doors. lol
 

·
Registered
Joined
·
756 Posts
Wow good deal. How much did it set you back and what was involved in the fix?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
The VBCM was $63 with tax from local dealer and literally went in in 2 minutes. Remove the 2 7/32 hex screws from under passenger dash. VCBM is attached to heater box / phlenum facing upwards. Pop off the 4 pin connector, replace and BOOM you're done.
 
1 - 5 of 5 Posts
Top