Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
894 Posts
Discussion Starter #1
A typical clunk that has me boggled..

This is a single clunk. Seems to only happen when in drive (not reverse). Also happens when in nutural coasting down the road to rule out driveline issue.

Doesn't happen when stopped and brakes are pressed a few times.

Happens when doing 15mph or slower.

It has a hefty metal on metal clunk.
Sounds like it's coming from only one side, but loud enough to be confused with driver side.

Took the tire off.. Everything seemed tight.

Also, if driving down the highway, and I take the exit from 75mph and first time I get slow to make a sharp turn, I don't hear the clunk. But from that point on, it comes back. Same if I back out of my driveway, and first time I press on the brakes going forward, no noise, again until the second time there on out.

Ideas?
 

·
Registered
Joined
·
2,653 Posts
clunk

A typical clunk that has me boggled..

This is a single clunk. Seems to only happen when in drive (not reverse). Also happens when in nutural coasting down the road to rule out driveline issue.

Doesn't happen when stopped and brakes are pressed a few times.

Happens when doing 15mph or slower.

It has a hefty metal on metal clunk.
Sounds like it's coming from only one side, but loud enough to be confused with driver side.

Took the tire off.. Everything seemed tight.

Also, if driving down the highway, and I take the exit from 75mph and first time I get slow to make a sharp turn, I don't hear the clunk. But from that point on, it comes back. Same if I back out of my driveway, and first time I press on the brakes going forward, no noise, again until the second time there on out.

Ideas?
Let's throw out some ideas:
1. utilitrac bed rail cover
2. spring leaf bracket broken
3. play in driveshaft
4. did you check the inner pads?
5. enough fluid in brake line?
 

·
Registered
Joined
·
894 Posts
Discussion Starter #3
This clunk is deff from the front passenger side.
 

·
Registered
Joined
·
4,396 Posts
It could be a shot coilover. Broken spring or maybe the shock/strut within the spring is toast. But I lean towards something bad in the axle assembly (cv joint?).
 
1 - 5 of 5 Posts
Top