Nissan Titan Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
1,130 Posts
Discussion Starter #1
AGAIN!!!!!!!!!!!!!!!!!!!!!
I got my new one Installed 3,000 miles ago after having it break because of the WRp Pulleys... And now it broke again and I this time I dont have the Puleys on so I have no Idea what the heck broke it this time.....

Any ideas... Im really mad with the truck right now... After having it almost 2 months in the dealership the first time I was so happy that I had everything working she was running like a mad truck and now it dead again....:scheibe-big: :scheibe-big: :scheibe-big: :scheibe-big:
 

·
Registered
Joined
·
1,411 Posts
yikes...i was just wondering about this the other day, i never saw your outcome...hope they figure out whats going on
 

·
Registered
Joined
·
494 Posts
Maybe the pulley's did enough damage to your crankshaft that it is out of wack too which will then vibrate and kill your flexplate over and over until the whole engine goes? Just a thought.
 

·
Registered
Joined
·
4,396 Posts
Man, that really bites. Maybe the install wasn't quite right?
 

·
CTs Little Chihuahua
Joined
·
5,285 Posts
Dubie2003 said:
Maybe the pulley's did enough damage to your crankshaft that it is out of wack too which will then vibrate and kill your flexplate over and over until the whole engine goes? Just a thought.
thats a thought...... sounds like thats what happened.
 

·
ClubTitan's little Pit Bull
Joined
·
6,553 Posts
Whoa, I must have missed a few threads...last time I heard, you chose to keep the WRP pulley installed because you thought it was running fine? Holy cow!
 

·
Creator of the DUMBEST thread ever!
Joined
·
4,107 Posts
RedTitanLE said:
Whoa, I must have missed a few threads...last time I heard, you chose to keep the WRP pulley installed because you thought it was running fine? Holy cow!
and go against a 100 titan owners telling him to take it off??? nooooo he wouldn't have done that.
 

·
CTs Little Chihuahua
Joined
·
5,285 Posts
jhromy's sig pic says it all. we all told him to remove before something bad happens. good luck luis.
 

·
Registered
Joined
·
1,130 Posts
Discussion Starter #9
I removed it 300 miles before the fiest one broke....
Got a new one installed and 3,000 miles later its brken again....
This time it has nothing to do with the pulleys..........
 

·
CTs Little Chihuahua
Joined
·
5,285 Posts
luis5.6 said:
I removed it 300 miles before the fiest one broke....
Got a new one installed and 3,000 miles later its brken again....
This time it has nothing to do with the pulleys..........
them pulleys didnt hold vibration like the stock ones did. (harmonic dampner) well the all that vibration the drivetrain took instead of the dampner something stayed messed up causing flexplate damage. (or bad installation of flexplate.)
 

·
Registered
Joined
·
824 Posts
Just another example of everybody is full of it till it happens to me.

Unfortunately the damage may have already been done, hopefully it was just a bad plate to start with this time or a bad install. Just tough to believe the pulleys haven't been on, you said before you took them off and didn't, so what do we believe this time. Call that buddy at WRP and see what he says about it, we all know we respect his opinion now don't we. I know you got tired of hearing about it but the "I told ya birds are a flockin". Hope it is something minor this time, and I hope this is a lesson learned, theory in harmonics has a purpose, the Titan didn't need a boat anchor on the front, so the balancer did have a mission.
 

·
Registered
Joined
·
1,130 Posts
Discussion Starter #12
Sftail1990 said:
Unfortunately the damage may have already been done, hopefully it was just a bad plate to start with this time or a bad install. Just tough to believe the pulleys haven't been on, you said before you took them off and didn't, so what do we believe this time. Call that buddy at WRP and see what he says about it, we all know we respect his opinion now don't we. I know you got tired of hearing about it but the "I told ya birds are a flockin". Hope it is something minor this time, and I hope this is a lesson learned, theory in harmonics has a purpose, the Titan didn't need a boat anchor on the front, so the balancer did have a mission.
Becaue of people like you is why I havent been posting / coming in the forums that much latetly....Why dont you call your buddy @ WRP since you like him so much and talk about him in almost every post you do....

I never lied about taking it of the first time... When I said they where of the truck they where Believe I got allot of PM form allot of members telling me to take them of so I did... 300 miles after the plate broke...
Got a new on installed and after just almost 3,000 miles it broke again...
AND the pulleys where not on the truck... Had to be something is messed up from the first time or a bad installation...

Isnt there anybody that does a better flexplate for our trucks?? An offroad version??
 

·
Registered
Joined
·
824 Posts
Sorry

luis5.6 said:
Becaue of people like you is why I havent been posting / coming in the forums that much latetly....Why dont you call your buddy @ WRP since you like him so much and talk about him in almost every post you do....

I never lied about taking it of the first time... When I said they where of the truck they where Believe I got allot of PM form allot of members telling me to take them of so I did... 300 miles after the plate broke...
Got a new on installed and after just almost 3,000 miles it broke again...
AND the pulleys where not on the truck... Had to be something is messed up from the first time or a bad installation...

Isnt there anybody that does a better flexplate for our trucks?? An offroad version??
Hey I am not trying to bust your chops on this, and I am sorry if I offended you with that comment, but I can also go back to post after post with you defending those pulleys. That is exactly the reason I post what I do about the guy because I think he has done enough damage with his get rich quick scheme at Titan owners expense. So you can't blame me for not coming in here when you were warned about that guys junk, and I can go back and show the posts where you said you took them off and didn't, like I said before many times over. Those pulleys and the failures that happened are just too coincidental to have those failures and each and every truck has had those pulleys on one time or another. You stood up so tall when you had them when everyone else had the problem and defended them, well now the boat has a hole in it and you expect others to sympathize with you on how could this have happened to me. It doesn't neccessarily matter that you don't have them on now, hopefully it is just a "coincidence" that it happened again, it isn't a coincidence that it happened the first time. The info was there. So once again, sorry to have said some things you didn't like, but you didn't exactly help the cause before either with your proud example of a truck with the pulleys that hasn't had a flexplate problem. The story is different now and I didn't cause it. Whether you think so or not, I do empathize with you on the problem, I truly hope it doesn't end up being a bigger problem. So I am sorry if I hurt your feelings, but I am a straight up guy and will say what I think, and the truth isn't always pleasant.
 

·
Registered
Joined
·
296 Posts
Is the dealer going to replace this one under warranty?
 

·
Registered
Joined
·
2,413 Posts
I hope it works out for you man!
 

·
Registered
Joined
·
1,130 Posts
Discussion Starter #17
I really dont know where SFtail is reading but i never lied about the pulleys being off and them no being off... As soon as I got allot of pms and allot of blablabla about them I took them off, and 300 miles after the plate broke... I now I should of listened but I really liked the gains of the pulleys...
Second time around and also no pulleys installed... I think it was an instalation error... but we will see....

YES its going to be covered under warranty!!!!!!!!

Cant wait to have my truck back she was runing like a raped ape!!!!!!!!!!!!!
 

·
CTs Little Chihuahua
Joined
·
5,285 Posts
luis5.6 said:
I really dont know where SFtail is reading but i never lied about the pulleys being off and them no being off... As soon as I got allot of pms and allot of blablabla about them I took them off, and 300 miles after the plate broke... I now I should of listened but I really liked the gains of the pulleys...
Second time around and also no pulleys installed... I think it was an instalation error... but we will see....

YES its going to be covered under warranty!!!!!!!!

Cant wait to have my truck back she was runing like a raped ape!!!!!!!!!!!!!
you shouldnt have sold ur cams man youre missing out on alot of hp there.
 

·
Registered
Joined
·
1,130 Posts
Discussion Starter #19
YEAH I think about that every day!!!!!!!!!!!!!!!!!!!!!
Still haunts me..........
Now i dont have the $$$ TO GET THEM.... And more importanlty an excuse for the wife on gettign them.......:)

But she was really moving with the new header/cat setup and new tune!!!!!!!!!! Cant wait to get her back, slap on the 17" wheels and go to the track!!!
 

·
Creator of the DUMBEST thread ever!
Joined
·
4,107 Posts
luis5.6 said:
I really dont know where SFtail is reading but i never lied about the pulleys being off and them no being off... As soon as I got allot of pms and allot of blablabla about them I took them off, and 300 miles after the plate broke... I now I should of listened but I really liked the gains of the pulleys...
Second time around and also no pulleys installed... I think it was an instalation error... but we will see....

YES its going to be covered under warranty!!!!!!!!

Cant wait to have my truck back she was runing like a raped ape!!!!!!!!!!!!!
i know one time for sure you said they where off but they were not... you made conflicting post... and some of us remember your races up to 140 with the stock ecu.
 
1 - 20 of 30 Posts
Top