Nissan Titan Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Hey guys, does anybody know why my cruise control is not working?
The only thing I can think of is that it has to do with an aftermarket radio being in place of my factory radio. It was like this when I bought it, I've checked all the fuses and can't figure anything else out. Any help would be much appreciated.

And my cruise control is located on my steering wheel.

Sent from my SAMSUNG-SGH-I897 using AutoGuide App
 

·
Registered
Joined
·
1,676 Posts
Hey guys, does anybody know why my cruise control is not working?
The only thing I can think of is that it has to do with an aftermarket radio being in place of my factory radio. It was like this when I bought it, I've checked all the fuses and can't figure anything else out. Any help would be much appreciated.

And my cruise control is located on my steering wheel.

Sent from my SAMSUNG-SGH-I897 using AutoGuide App
I don't think it would be your radio but I really hope you get it fixed ..
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #3 ·
Thanks, me to!

Sent from my SAMSUNG-SGH-I897 using AutoGuide App
 

·
Registered
Joined
·
88 Posts
Do you also have the steering wheel controls working for the aftermarket stereo?

Pop the column cover off and make sure the connectors are all plugged in completely.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #5 ·
No I don't have the steering wheel radio controls wired up to the aftermarket radio. Not sure how to do that.

Are you referring to the steering column cover? If so, if that easy to do?

Sent from my SAMSUNG-SGH-I897 using AutoGuide App
 

·
Registered
Joined
·
4,396 Posts
If the stereo was recently installed and the cruise control stopped working after that then I would blame the stereo. Otherwise, I think the speed sensors at each wheel can cause cruise control issues. But I would expect to see a warning light on the dash if that was the case.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #7 ·
I really don't know when it happened, it was like this when I bought the truck. Didn't realize the cruise control didn't work until a week later after I bought it.

Sent from my SAMSUNG-SGH-I897 using AutoGuide App
 

·
Registered
Joined
·
4,396 Posts
Check all your fuses too.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #9 ·
Will do thanks!

Sent from my SAMSUNG-SGH-I897 using AutoGuide App
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #10 ·
UPDATE: last night I was checking all my plugs under my steering wheel and what ever else I could see. I made sure they were all connected good and pushed all the buttons on my steering wheel a couple of times making sure none of them were stuck. Got in my truck today and the cruise control is working, don't know what I did but glad I did it.

Sent from my SAMSUNG-SGH-I897 using AutoGuide App
 

·
Registered
Joined
·
4,396 Posts
Your Titan just wanted some TLC. :)
 

·
Registered
Joined
·
3 Posts
When you cruise control wasn't working, on the dash did the Cruise message come but only flash the Set lights? My cruise control worked just fine for a couple of trips but then the other week, I tried to set it but it would just keep flashing the Set message and never engage. I dont know why it suddenly decided to stop working. But later that same day on the way home, I tried it again, and it worked just fine. Was your issue similar?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #13 ·
Yes that is exactly what mine was doing, except when I first bought the truck a couple of weeks ago not even the cruise light would come on.

Sent from my SAMSUNG-SGH-I897 using AutoGuide App
 

·
Registered
Joined
·
3 Posts
thats interesting. I haven't been able to check the fuzes yet because I have been so busy with work and all. But I plan on doing that tonight. The otherthing is I have everything stock in my Titan, no aftermarket stereo or anything. Hopefully thats all we have (or had) was a bad connection somewhere.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #15 ·
Well it wouldn't come on again and I pushed on the switch and it popped like it was not seated all the way on the steering wheel and it started working again. So I'm just gonna buy a new switch and see what happens.

Sent from my SAMSUNG-SGH-I897 using AutoGuide App
 
1 - 16 of 16 Posts
Top