Nissan Titan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just bought a 2007 nissian titan with a 6" lift and 35" tires on it. The problem is when i accelerate the drive shaft hits the bottom of the cab. Also when i come to a stop I swear the rear end drops like it is on a bind. I can take off fast and the driveshaft hits the cab but then let off the gas and the rear end makes a pop noise and all is good until i stop again. I tried the helper springs for axle wrap thinking maybe would help but no go. It is getting really annoying. Thanks for the help.
 

·
Registered
Joined
·
1,271 Posts
Broken tranny mount? I'm not sure man. Do you have a driveshaft spacer?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I think the the guy I bought it from had a longer drive shaft made for the truck. He said it worked for awhile but then started to make noise again. He told me the transfer case was out of it but i disagree. The truck works fine in four wheel drive. It is like something is either to long or to short. Just can't pin point.
 

·
Registered
Joined
·
494 Posts
Can you see where it is hitting the cab?

Your Carrier bearing may be bad but that is a visual thing. Your tranny mount may be fubared, it has happened to others. Your motor mounts may be going out and that popping in the diff is horrible. I would probably remove the diff cover to take a look at the gears. You may find that pop is actually the spiders grinding together.
 
1 - 4 of 4 Posts
Top