Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2004 Titan and for the past few weeks I hear a flapping noise from the blower diverter duct under the dash. I havent had time to really get in depth on the problem, and I was just wanting to know if anyone else has had this problem and the solution to fix it.
 

·
Registered
Joined
·
8 Posts
Me too!

I've had what sounds like the same problem for a very long time. It very interrmitent in the beginning, but does it everyday now. Very annoying to say the least. Looks like I may have to get up under the dash and mess with the motor.
 

·
Registered
Joined
·
2,629 Posts
Add me to this list........mine has a pretty disturbing clicking sound that just started this past week. Like something is preventing the vents from shifting properly.

For example, everytime I turn the dial to max AC, after a short pause, I will get several clicks and then it won't make another noise till I shift it to another position..........sucks

Does this sounds like the same problem that you guys are having?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Mine is getting worse. Now mine is doing it when you turn the key off and the truck seals the vents up by its self. It used to just flap once or twice before it finally stopped now it is doing it about 8 to 10 times. It sounds now like there is a gear slipping on that flap. I am not sure how the diverter duct flap is even being controlled on the titan, with a actuator arm motor and gear cluster or what. Any help is greatly appreciated guys!
 

·
Registered
Joined
·
1,211 Posts
I've had this problem for a while too, only mine happens everytime I switch from defrost to another setting or vice versa, its a very disturbing clicking sound. I actually kind of forgot about it since I don't use defrost very much in the summer, but over the last week I've been reminded of the problem.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
That is my problem! What did you do to fix it and how hard was it to do? I saw a part number of the part you ordered but then the thread ends was this the right parts?
 

·
Registered
Joined
·
271 Posts
I have changed the motor on the passenger side a couple of times. The only hard part was actually getting to the screws that secure it to the airbox. The motor is very straight forward. Mine is also doing the same thing, just to lazy to fix it. LOL.
 
1 - 8 of 8 Posts
Top