Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
ok guys im lost. The ride quality friggin stinks. its hard to explain but it seems very loose up front and shudders when going over any small imperfection in the road. the ride quality has seemed to deteriorate since i got the ol gal. i replaced the rotors and pads which helped with the shudder in the steering wheel but not the ride quality. had wheels rotated and balanced a couple of different times. replaced front shocks. now what? end links? upper control arms? lower ball joint? no play in the wheel when i have it jacked up. any help would be much appreciated.
 

·
Registered
Joined
·
756 Posts
I had that happen to me and found out there was a "bubble" in one of the front tires. Not on my T but another vehicle. Anyway, to check for the bubble just run both your hands around the tire. Good luck.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #4
2004 CC, se with 70k. no mods on the front suspension.

i thought about the bad tires also so had 2 of them replaced to see. didnt help :(
 

·
Registered
Joined
·
1,107 Posts
Would have to be some sort of rubber bushings I'd imagine...ball joints, tie rod ends etc. It's actually the first I've heard of this type of complaint. have you had anyone look at it...like the dealer or a trusted mechanic? I wish I had more info for you...sorry I can't be more helpful. Let us know how you make out though. It may be helpful to others.
 

·
Registered
Joined
·
451 Posts
Didn't see alignment in the list... ?
 

·
Registered
Joined
·
82 Posts
Discussion Starter #8
so i wanted to rule out rotors and pads again. i went and had my OEM rotors turned and replaced the crappy duralast ones i had on there(my rant on duralast parts with have to be another thread i guess), also went with wagner thermoquiet pads. if that doesnt work ill have to go with hudsonvalley's suggestion and take it in to the dealership. any other ideas on something i could rule out?
 
1 - 8 of 8 Posts
Top