Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
On a Friday night a few months ago, my2004 Titan 5.6 SE stalled out on the freeway and would not start up again. I had it towed to a shop highly recommended by a friend of mine. The following Monday the shop told me that the fuel gauge sending unit had failed and that my fuel pump had failed (fuel gauge showed a half full tank). So both were repaired.
Not too long after, my truck started doing this thing where it would start and run fine. But when I went to restart, the engine would start and die immediately (like it was choking out). When I again restarted it, it would crank for awhile before turning over again. At first I was thinking that the injectors were just trying to flush crap from the bottom of the fuel tank. But instead of getting better, it only got worse. I talked to the mechanic who installed the fuel pump, and he said it sounded like the coolant temp sensor had failed. I didn’t think to ask him why that wouldn’t have generated a code and check engine light.
I had an oil change scheduled with my regular mechanic, so I described the problem and asked him to look into it. He thought it was odd that the other mechanic dismissed the possibility of a faulty fuel pump so readily without looking at it.
As often happens with these things, my regular guy could not duplicate the issue I was having. But he had attached a fuel pressure gauge while trying to find the problem. Fuel pressure was at 47 psi while running, dropped to 30 psi 20 minutes after shutting off the engine, and then dropped again to 20 psi upon restart. Regular guy says it should not have dropped 27 psi when engine turned off, and definitely not drop another 10 psi upon restart. Talked to fuel pump mechanic, and he says of course it dropped 27 psi when you turn the engine off because the pump is off. And besides, your mechanics ful pressure gauge probably has a leak in it (wtf?) Again, I didn’t think to ask wouldn’t you know if your fuel pressure gauge had a leak because you would have fuel on your hands? So I’m caught between two mechanics. It does seem as though the one who installed the fuel pump is trying to mitigate the situation because the work is still under warranty, but I don’t know for sure. I’m hoping someone with more experience with these things can illuminate the situation for me. I just want my beloved truck to be reliable again.
 

·
Registered
Joined
·
8 Posts
I'm sure there are other with more knowledge about this matter. I'm not home to look under hood of my 04 titan but I'm curious if there is pressure regulator on fuel rail.
 

·
Registered
Joined
·
26 Posts
I have a 2005 Titan. It did just about the same thing was running along fine and then just quit. Had it towed to a shop and they initially thought it was the fuel pump but they did some more testing and found out it was the mass oxygen sensor. Apparently, it can mimic the same symptoms and the oxygen sensor although expensive, not as much as replacing the fuel pump. I have not had any issues since and that was two years ago.
 

·
Registered
Joined
·
1 Posts
I have nvere seen a coolant temp sensor cause a no start condition before but anything is possible. Usually if one fails it's causing a very high idle because it's reading cold (-40 if you have a scan tool) and it's dumping fuel in the system. The only way I could see one causing a no start would be if the wiring is sooner back some where causing a short and a wiggle test (yes that is what it's called) will so evidence of this just by shaking the wires.
 
1 - 5 of 5 Posts
Top