Nissan Titan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hey Folks, I hope your all finding ways to stay out of trouble in this crazy world and wish you all the best of health.

I've just had two engines fail on me in a week and as a freelancer just lost a 6 month job due to Covid19 and am trying to get by on pennies. I can't afford to go to a mechanic and I really need some transport.

I thought my 06 Titan had done a head gasket as I was down to about 75% power... I tried to limp to a safe place and power dropped to about 25% and it was missing and spluttering all over the place under load.

Anyway.... Got a good deal on a Subaru, then I found out why on Saturday why, when a camshaft seized.

Today I got to have a better look at the Titan.

Compression tests on the cold engine all came in 170-180psi.

Idle is reasonable, but it is making a puffing noise like an old steam train... Exhaust leek?

When I pull each plug at idle the RPM drops a little as expected.

There seems to be a little more power on the cold engine and once it warms up, it's dire. (I had to limp up my hill in two go's)

Could it be as simple as an advance sensor or something like that?

I've had a Crankshaft sensor code forever and have tried several brands of replacement, but it keeps coming back.

The only other occasional code is the Catalytic Converters are on the way out.

Thank you all for any help or advice you might offer.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #2
Looks like clogged cats.

I popped the O2 sensor on the right bank today and just with that little hole, there is a massive improvement.

Good luck out there.
 
1 - 2 of 2 Posts
Top