Nissan Titan Forum banner
1 - 20 of 31 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
I installed the leaf spring helpers on my 05 to Titan (actually tighten) up the rear end. I did NOT have any clunking just wanted a little more control. It worked as described and has a totally different feel. I LIKE IT!

Has anyone else noticed that the bracket that the U-bolts go into closest to the axle on top of the existing leaf springs has about 3/4 inch or less clearance from the rear tires?

Do you think that could be a potential problem? I know if the helpers come loose or break that could be bad for the tire or worse become a projectile that could come through the body of the truck. (I had metal objects laying on the road or thrown across the road at me from another vehicle come through 2 different cars from underneath)

Any thoughts from someone who has done the mod?

Ps. They were installed in front of the axle and sit about 1.5 inches from the bolt of the leaf spring where is mounts to the frame. I don't think it could move forward any if it wanted to. I did NOT jack or lift the truck to install them either.
 

·
Registered
Joined
·
2,489 Posts
They're too far forward, move them back a couple of inches. then the backing plate won't be near the tire.
The front bolt (horizontal) is just behind the plastic retainer.
See pic.
 

Attachments

·
Registered
Joined
·
86 Posts
Discussion Starter · #3 ·
Did you have to jack the rear up? I could NOT get the leaf spring helper on unless I shifted it forward. Rememer this is an 05 I think most of the ones were on 04 models. I also have the Offroad package.

I paid $33 for mine at a local parts store. They are the 3 position ones. Maybe I need Longer U-bolts or need to compress the leaf spring with a clamp or something.
 

·
Registered
Joined
·
791 Posts
Kuli said:
I installed the leaf spring helpers on my 05 to Titan (actually tighten) up the rear end. I did NOT have any clunking just wanted a little more control. It worked as described and has a totally different feel. I LIKE IT!

Has anyone else noticed that the bracket that the U-bolts go into closest to the axle on top of the existing leaf springs has about 3/4 inch or less clearance from the rear tires?

Do you think that could be a potential problem? I know if the helpers come loose or break that could be bad for the tire or worse become a projectile that could come through the body of the truck. (I had metal objects laying on the road or thrown across the road at me from another vehicle come through 2 different cars from underneath)

Any thoughts from someone who has done the mod?

Ps. They were installed in front of the axle and sit about 1.5 inches from the bolt of the leaf spring where is mounts to the frame. I don't think it could move forward any if it wanted to. I did NOT jack or lift the truck to install them either.
I removed mine today for this exact reason. I am having new rims and tires put on here in a few days and that bracket won't clear my new tires. I had mine installed like the directions say though because I was looking for some added load stability. I am sorry to say they failed miserably which is another reason I removed them. Don't let that discourage anyone from using them as JetTech discovered. They seem to be working great as a traction bar.
 

·
Registered
Joined
·
2,489 Posts
Kuli said:
Did you have to jack the rear up? I could NOT get the leaf spring helper on unless I shifted it forward.

I paid $33 for mine at a local parts store. They are the 3 position ones. Maybe I need Longer U-bolts or need to compress the leaf spring with a clamp or something.
Sounds like you got the same ones I did.
The front U bracket which attatches with the horizontal bolt, needs to be bent.
From (__) to (_), does this make sense?
That way it will allow you to move the bars further back, and the horizontal bolt holes will be longer to handle the thicker area with two leafs (instead of one)
I had the rear wheels on ramps, my LE's running boards are ALWAYS in the way. I'm half-Tempted to pull them off! LOL
 

Attachments

·
Premium Member
Joined
·
2,788 Posts
Tattoomee said:
I had the rear wheels on ramps, my LE's running boards are ALWAYS in the way. I'm half-Tempted to pull them off! LOL
I know where you can send them if you ever do..... 8)
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #7 ·
It makes perfect sense as your picture show you reformed the front brackets so that the top part where the bolt goes through had more length on it at the top and hugs the leaf spring at the bottom rather then stick out 1/2 inch.

(I have been taught over 23 years not to use the word bent) I have to deal with customers alot and reform always sounded better then bent.
Modified is actually a better term.

Thanks, I will look at it this weekend.
 

·
Registered
Joined
·
791 Posts
JetTech said:
Tattoomee said:
I had the rear wheels on ramps, my LE's running boards are ALWAYS in the way. I'm half-Tempted to pull them off! LOL
I know where you can send them if you ever do..... 8)
Jet, keep your eye open for my set that will be coming off this weekend. If your interested, I'll give you first crack at them. I don't even know what to ask for them really.
 

·
Registered
Joined
·
2,489 Posts
Kuli said:
(I have been taught over 23 years not to use the word bent) I have to deal with customers alot and reform always sounded better then bent.
Modified is actually a better term.
Believe it or not...I was trying to think of a better word, but "Bent" was all I could Think of?!
Did you like my (_),(___)?
:lol: :lol: :lol:
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #10 ·
yes I like the (__) to (_) but I would not have understood that without the pic.
Ignore this as it is to fill in to make up fo(r) the characters needed
maybe I would have understood (__) to (_) if you can do it right with hard returns.
Oh well I edited this message 5 times and still cannot get the ( ) to show up on top of the line below it without text.

Did you REFORM them on the vehicle with a HAMMER or did you mark them and pull them off and use somethihng else like a vice?
 

·
Premium Member
Joined
·
2,788 Posts
TitanHauler said:
JetTech said:
Tattoomee said:
I had the rear wheels on ramps, my LE's running boards are ALWAYS in the way. I'm half-Tempted to pull them off! LOL
I know where you can send them if you ever do..... 8)
Jet, keep your eye open for my set that will be coming off this weekend. If your interested, I'll give you first crack at them. I don't even know what to ask for them really.
Heyyyyyyyyyyyy, now we're talking.....Just PM me when you're ready to sell and I'll see what I can do.

EDIT: Doh, I just noticed you've got a Kingcab... :cry: I don't think they'll fit a crewcab....will they??
 

·
Premium Member
Joined
·
5,842 Posts
Yeh definately let me know if you are going to take them off. I may very well get them from you. Then I could get those OEM bed rails and be almost done with this thing.........well hmm maybe I shouldnt say done. LOL
Let me know how much you are wanting for them. Are they in pretty good shape?
M4ck
 

·
Registered
Joined
·
2,489 Posts
Kuli said:
yes I like the (__) to (_) but I would not have understood that without the pic.
Ignore this as it is to fill in to make up fo(r) the characters needed
maybe I would have understood (__) to (_) if you can do it right with hard returns.
Oh well I edited this message 5 times and still cannot get the ( ) to show up on top of the line below it without text.

Did you REFORM them on the vehicle with a HAMMER or did you mark them and pull them off and use somethihng else like a vice?
"If it Don't work the First time, Get a Bigger Hammer!"

Yes Sir, I used both Hammer and Vise.
I tried to "Mangle...oops, Modify" Them on the truck,
but couldn't get the angle right. (upside-down)

-Sorry guys, If I do pull the "runners", I'm gonna keep them with the vehicle.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #15 ·
Ok, I got home early today and reformed the brackets so they were taller to reach over the spot you put yours on. Here is the dilema and questions I have,

1. Did you use the rivet that came with them and what position furthest back or towards the front?

2. Did you have to compress the leaf spring to install the back part? My U-Bolts still are NOT long enough unless I jack up on the helper to put the u-Bolts on it and tighten it. Mine is on 05 it looks like the bottom leaf sticks down quite a bit.

It looks like it will lower the rear which I do NOT have a problem with. I will wait for you to reply while I paint those helpers black to look better and reinstall them this weekend.

Thanks
 

·
Registered
Joined
·
43 Posts
I installed them too and have a few pics up in another thread. I love em but one thing Im not to fond of is that front u-bracket. Seems kinda flimsy. Im not sure how much stress is being put on it. Im sure that if it did break the U-bolts would hold it secure long enough to remove them. I might even go get some modified u-bolts made so I can use a castilated nut and pin..Or more thread lock
 

·
Registered
Joined
·
2,489 Posts
Kuli said:
1. Did you use the rivet that came with them and what position furthest back or towards the front?

2. Did you have to compress the leaf spring to install the back part? My U-Bolts still are NOT long enough unless I jack up on the helper to put the u-Bolts on it and tighten it. Mine is on 05 it looks like the bottom leaf sticks down quite a bit.
A-1)The only mod I did was to form the front bracket into a tighter radius around the leafs, then mounted it just behind the plastic clamp (to keep it from migrating forward) where two leafs are 'joined'.

A-2)I had them previously installed, and 'apparently' it compressed the lower spring enough to get the u-bolt around it.

I'll try to take some more pics to help you out, but currently I need to wait for this rain (sent by the Californians) to pass! LOL!
 

·
Registered
Joined
·
791 Posts
JetTech said:
TitanHauler said:
JetTech said:
Tattoomee said:
I had the rear wheels on ramps, my LE's running boards are ALWAYS in the way. I'm half-Tempted to pull them off! LOL
I know where you can send them if you ever do..... 8)
Jet, keep your eye open for my set that will be coming off this weekend. If your interested, I'll give you first crack at them. I don't even know what to ask for them really.
Heyyyyyyyyyyyy, now we're talking.....Just PM me when you're ready to sell and I'll see what I can do.

EDIT: Doh, I just noticed you've got a Kingcab... :cry: I don't think they'll fit a crewcab....will they??
Yikes! Nope, I think they are different. Sorry. Forgot you had a CC.
 

·
Registered
Joined
·
791 Posts
BiXLL said:
m4cks lookin for a set for KC!
Ah! Well then I will give HIM first crack at them. :) As far as I know they are in great shape but once they come off I will shoot a bunch of pictures and let you decide. It will also depend on whether or not I hate the nerf bars that I am replacing them with. I will let you know, I'll PM you M4Ck.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #20 ·
I still have one question.
Did you use the Rivets that came with it and if so which position.
Oops that was 2 questions


Dave
 
1 - 20 of 31 Posts
Top