Nissan Titan Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
Unsure if there is already posts on this, but my titan had been sitting at my parents house for about three years, it would be turned on twice a month. i recently started using it again, i put a rough country 3in lift on it. Had the ses light on, autozone said o2 sensor, bank 2, replaced it, light stayed on same o2 sensor causing it. Few days later, after i let it to my cousin, lost power, truck was still on but no response on the gas pedal, truck is just barley rolling on drive, b-lsd light is on. Had to turn it on and off over and over again to get it home. good thing i wasnt on the freeway. Any clues to whats wrong with my truck? Havent done cat or ecu recalls yet.
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #2 ·
Well took the titan to the dealership, had the recalls done, had told them about the truck losing powerand blsd light coming on. Picked it up the truck today ses light off, the 02 sensor was loose, said it was all fixed up, got about a block down the road same problem, loss of powe, blsd and ses light back on. Tool it back the shop was already closed talk to the serivce manager, he tool it out on a drive he didn't experience the sane problem but he said ses light was coming on and off. Gotta wait till Monday before they can check it out. Damn
 

·
Registered
Joined
·
563 Posts
There is a recall on the ECM relay for '04 to '06 (regardless of miles). Mine started "failing" a week after I got the recall notice. First it lost power above 3000rpm, a few days later it could not get over 2000 rpm, but ran fine below 1800. It had set no codes/lights. Dealer did the recall and it runs fine (for almost a month).
 
1 - 4 of 4 Posts
Top