Nissan Titan Forum banner
1 - 20 of 32 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Well after reading about JetTech's success with $22, I decided to head off to Auto Zone today and pick up a set of leaf spring helpers. I CAN NOT emphasize enough how much I love these things on my girl. What a difference! I decided that I didn't want the shiny new look under there so I opted to subdue them a bit. Have a look:
 

Attachments

·
Registered
Joined
·
43 Posts
Discussion Starter · #3 ·
It certainly felt like it. Stiffened up quit a bit on the corners. You don't get that rocking feeling. Im impressed.
 

·
Premium Member
Joined
·
2,788 Posts
Glad you like them HH, it's a cheap, easy mod that makes the truck handle so much better. It also gets rid of that annoying clunking sound coming from the axle wind-up....Thanks for the pics and they look great painted... :)
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #5 ·
No thank you for all the help you guys give!
 

·
SHIFT_I did it the hard way... I earned it.
Joined
·
4,341 Posts
I need to do this. I don't think I have the sway on the corners or the clunk from the axle, but I don't like the funky feeling I get coming down off of speed bumps and out of dips. It might be interesting to see how it feels after installation. Maybe I have these issues and don't know it.
 

·
Registered
Joined
·
601 Posts
I heard a nasty rumor that these things can cause a 1/2" drop in the rear. Is this true?
 

·
Registered
Joined
·
601 Posts
JetTech said:
HavockWK said:
I heard a nasty rumor that these things can cause a 1/2" drop in the rear. Is this true?
Yes, it will cause the rear to drop about 1/2"
Thanks for the confirmation. I am going to lift the rear with some small blocks, so I guess I will just have to figure the 1/2 loss out of the gain from my blocks if I choose to test these out. But for $22 bucks, I guess I don't have much to lose if I don't like them.
 

·
Registered
Joined
·
791 Posts
I installed these behind the axle (the way the directions say) as I was looking for some temporary load stability (until my airbags are available) when towing my trailer. I have the PRG Leveling Kit installed and I was disappointed to see the rear end drop 1/2 to 3/4 of an inch from stock giving my truck a noticeable prerunner look (which I kind of like but knew it would be ugly once my trailer hit the ball). They did nothing for the sway or my rear end sag with the trailer connected as they claim. Looks like I will be removing them ASAP and possibly reinstalling them in front of the axle as it looks like they are much more effective there. For those that haven't done the leveling kit this sounds like a great mod to soften the rake and get better traction. Hard to beat for $22.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #12 ·
TitanHauler said:
Looks like I will be removing them ASAP and possibly reinstalling them in front of the axle as it looks like they are much more effective there. For those that haven't done the leveling kit this sounds like a great mod to soften the rake and get better traction. Hard to beat for $22.
Definetley got to put em forward of the axle. Once you do Im sure you will be most pleased. You'll still be able to chirp em too.
 

·
Registered
Joined
·
64 Posts
just my luck

Hi, I've been lurking here for awhile and I try to read up on as much as possible. I really dig this site and all the people who put some much time, effort and money!! into making the Titan a better vehicle. Anyways, I decided to get the $22 helper springs from my local Autozone, and installed them before going to work. I took a couple practice runs around town, came back checked the springs, everything was ok.
Got back in the truck, drove out of my complex, went down a small dip and gunned it. thats when the helper spring snapped but only on the passenger side. So now i tell everyone at work that the Titan has so much torque, it eats leaf springs. 8) Well I figured that maybe that one spring was just faulty, ill post pics if anyone wants to see what mean.


Paul[/u]
 

·
Registered
Joined
·
791 Posts
Re: just my luck

monster said:
Hi, I've been lurking here for awhile and I try to read up on as much as possible. I really dig this site and all the people who put some much time, effort and money!! into making the Titan a better vehicle. Anyways, I decided to get the $22 helper springs from my local Autozone, and installed them before going to work. I took a couple practice runs around town, came back checked the springs, everything was ok.
Got back in the truck, drove out of my complex, went down a small dip and gunned it. thats when the helper spring snapped but only on the passenger side. So now i tell everyone at work that the Titan has so much torque, it eats leaf springs. 8) Well I figured that maybe that one spring was just faulty, ill post pics if anyone wants to see what mean.


Paul[/u]
You broke the helper spring or the mount???? If you broke the spring, this I gotta see!
 

·
Registered
Joined
·
4,694 Posts
Re: just my luck

monster said:
Hi, I've been lurking here for awhile and I try to read up on as much as possible. I really dig this site and all the people who put some much time, effort and money!! into making the Titan a better vehicle. Anyways, I decided to get the $22 helper springs from my local Autozone, and installed them before going to work. I took a couple practice runs around town, came back checked the springs, everything was ok.
Got back in the truck, drove out of my complex, went down a small dip and gunned it. thats when the helper spring snapped but only on the passenger side. So now i tell everyone at work that the Titan has so much torque, it eats leaf springs. 8) Well I figured that maybe that one spring was just faulty, ill post pics if anyone wants to see what mean.


Paul[/u]
Damn, I got see this. :D
 

·
Registered
Joined
·
64 Posts
just got out of work heres the pics, ill try to get better ones in the daylight. the noise that leaf made when it snapped 8O i almost had a heart attack
 

Attachments

·
Registered
Joined
·
64 Posts
anybody else having problems seeing the pics?
i'm pretty sure i did this right.
 

·
Registered
Joined
·
601 Posts
monster said:
anybody else having problems seeing the pics?
i'm pretty sure i did this right.
Yes, I can see them when I click to download them. Of course I have to use this crappy firefox browser because IE doesn't like M4ck's choice of forum software. Oh well, I only use it for this forum, so I call it "M4ck's Special Browser".
 

·
Registered
Joined
·
601 Posts
HavockWK said:
Yes, I can see them when I click to download them. Of course I have to use this crappy firefox browser because IE doesn't like M4ck's choice of forum software. Oh well, I only use it for this forum, so I call it "M4ck's Special Browser".
BTW... I don't blame M4ck. I thank him for all the hard work he has put into this forum. I just sometimes let the smarta$$ come out and visit. :hypnotiz:
 
1 - 20 of 32 Posts
Top