Nissan Titan Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2005 Titan LE 2WD Automatic 130-135K. I noticed my Trans temp was getting high. The last time I had this problem I had a hose leaked which I fixed on the side of the road and problem solved (had about 75K). Fast forward to now, I found no leaks so I decided to drain, fill, replace filter on the transmission. I did not see anything out of the ordinary looking at the trans fluid. Trans temp still runs high, but now has a hard time going from 4th to 5th engine revs and it shifts hard, and notice the check eng light. I pulled a P1716 code. Looking at the FSM its a Turbine Rev S/CIRC. I did take it to a garage and they said I needed a new Transmission. I don't want to condemn the trans yet especially since its only at 135K took me 15 years to get it that high. I know sometimes the Titan trans acts squirrely when something is not right especially the high temp (last time it was a leaking hose, and yes the trans acted the same way when that happened). I cant seem to figure out where this Turbine Rev Sensor is and when I look up parts the only sensor that comes close is called SENSOR ASSY-REVOLUTION- #31935-90X02. Looking at past posts someone had posted a picture of a "speed sensor" located on the outside passenger side trans bell housing. But that was referring to an 04 Titan. Oh and by the way that part is discontinued. Does anyone know what replacement part I can use once I find the location of the Turbine Revolutin Sensor? Or do I condemn the Tranny and sell as is on Craigslist?
 
1 - 1 of 1 Posts
Top