Nissan Titan Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
HELP! If anyone out there knows anything about this, please respond. My 2004 Titan LE 4X4 has had 2 automatic transmissions break and now the third just broke. The transmission is under warranty (all of them were) but now the dealer is saying he will not warranty it unless I spend $800.00+ on a new wiring harness as they 'think' this may be the problem, no, nothing confirmed nor is there any proof. Does anyone know about this? A wiring harness that causes the tranny to break??? HELP PLease....Don
 

·
Premium Member
Joined
·
6,584 Posts
The wiring harness could cause the problems. The ECU and the TCU (inside the transmission) transfer data back and forth to each other, using the CAN. This data sets the transmission line pressure, shift points, etc. If the wiring harness is faulty this data transfer is interrupted, and could cause transmission failure.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Thank you so much for your help! Do you have any idea how they check this fault? I ask this because the first transmission died due to 'valve body' malfunction. The second transmission had a sensor inside the transmission that went 'bad' and could only be repaired by replacing the entire transmission but the third transmission gave me warning signs with heavy klunk sounds followed by not being able to move at all (the gas pedal to the floor and going 5) but finally a loud pop and it completely disengaged from the engine (dead). They also want to charge some obscene amount for the wiring harness, do you know if this is the correct dollar value? $800-$900? I appreciate any and all help!!! Thank you so much!
 

·
Premium Member
Joined
·
6,584 Posts
The harness should not cost that much, but if labor is included in that figure it could be correct.
 
1 - 5 of 5 Posts
Top