Nissan Titan Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Has this ever been done? Just wondering as I've heard some conflicting things as to what percentage of our trucks have this problem. Last week someone posted an offhand remark that "most trucks have the problem", while someone else posted that they heard it was between 10-15%. If I had to make a guess, I'd think it was the latter.

In any event, I know this wouldn't be scientific, but would at least represent the members of this forum.

Maybe we could ask the question, who has the judder/shudder and who has the long pedal travel and what year their vehicle is. With the large membership, I think the results would be interesting.

Just wondering.

Regards,

John
 

·
Registered
Joined
·
1,492 Posts
I got the shudder at about 18500. Took it in and it breaks like butta! I am at 21000 now.
 

·
Registered
Joined
·
253 Posts
Mine started at about 2000 miles. The dealership turned the rotors and then put on some new peices. I have 5700 now and it is doing it again. They are ordering me new rotors this time. Nissan won't let them turn the rotors again. The only bad thing is they are on back order because there are some many trucks with the problem according to the service department at the dealership.
 

·
Premium Member
Joined
·
5,842 Posts
Had my brake judder fixed 2 weeks ago at 10000 miles. Brakes like a dream now. Still wish it had been the permanant fix but oh well. When they do start doing them I will get her up there as fast as I can.
M4ck
 

·
Registered
Joined
·
16 Posts
does this problem exist for the latest '05 titans? mine's on order and has yet to be built, but this along with the spray-in bedliner problems seem to be the most common i'm seeing on these forums.
 

·
Premium Member
Joined
·
5,842 Posts
I believe you may run into it with a few earlier build 05's but the dealerships seem pretty easy to get the work done. I called them about mine and told them about the TSB and they said no problem just bring the truck down. I did and got it back that afternoon. Took a little longer than some of the other guys I have talked to on here but still was pretty quick. Plus they washed and cleaned it all up for me. Looked great and stopped perfectly when I left. I was pretty impressed with the service. On the other hand I was there with my dad walking around the parking lot for well over an hour and not one time did a salesperson come up and even say hello. Bad part of that my dad is in the market for a new vehicle. Oh well their loss.
M4ck
 

·
Registered
Joined
·
11 Posts
7200 miles. no problems mechanically. radio system changed out twice when new, disc changer did not work correctly.


Pilot write-up after flight; "lost number one engine inflight" Mechanic sign-off; "upon close inspection, found number one engine on left side of aircraft"

Jettech, I know it's old, but so is this. And I mean no insult to anyone.

Bert
 

·
Registered
Joined
·
294 Posts
Mine started to go at 2800 miles. I drive mostly city rarely on the highway and I have not towed with it yet. I have an appointment tomorrow to get it fixed. It gets progressivly worse with more miles. My brakes vibrate at speeds above 30 mph now. This is really the only problem I have had except the tire pressure flat warning at cold temp.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #10 ·
For the record I've had no problems with my 05. 2500 miles on it so far.
 

·
Registered
Joined
·
120 Posts
Mine's doing it right now, about 6,000 miles (9000KM). I'll let you guys know what the outcome is, for the record, after my dealer checkup.
 

·
SHIFT_I did it the hard way... I earned it.
Joined
·
4,341 Posts
Mine started doing it about 500 miles ago. I'm at 9000 right now. I'll have the TSB's done next week while I'm on travel and won't need the truck. Then again, maybe on Friday instead.
 

·
Registered
Joined
·
91 Posts
I'm at 4000 mi and no problems yet. I'm hoping the Judder will pass me by or at least wait until the permanent fix is out.
 

·
Registered
Joined
·
16 Posts
All sounds very familiar. I'm at 23k on the Armada and have been back for brake judder five times. Four times they actually worked on the brakes. The latest I recv'd new rotors, new pads, new hardware (not sure what new bolts will do but what the heck).

My advice is to keep taking your rig in for the brake fix (turn the rotors on the vehicle, new pads if needed) so you can document the repair history.

I have yet to see anyone post pictures of the fabled big brake fix.

Matt
 

·
Registered
Joined
·
2,413 Posts
I have 5800 miles and no brake problems. It's a 2004.
 

·
Registered
Joined
·
330 Posts
I haven't had any problems yet, got an 04 with just over 3400 miles on it.
 

·
Registered
Joined
·
2,653 Posts
I got the shudder at about 6500 miles. (always had the long pedal travel for the brakes but thought that was normal.)

I'm waiting for the TSB. The Service Manager said a "fix" would be here but I want a letter to guarantee me a "fix" and not a "patch" until it happens again a couple K later...

Mike
 

·
Registered
Joined
·
9 Posts
got mine at <4000 mi

'04 2wd. Dealer turned the rotors and no probs yet (nearing 7500 mi). Hope to get all new syst if it happens again.
 

·
Premium Member
Joined
·
9,246 Posts
04 with 7000 miles, no problems.
 

·
Premium Member
Joined
·
6,584 Posts
'04 Armada with 16,000 miles, no brake problems other than dust. Carbotech pads took care of that.
 
1 - 20 of 25 Posts
Top