Nissan Titan Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
247 Posts
Discussion Starter · #1 ·
Yesterday while driving & listening to music, I went to change the song on my CD and my entire radio just shut off. I tried turning it back on & had no success. The unit still has power (clock & lights still work), however it will not turn on. I checked all the connections on the back side & fuses and everything seems to be ok. Anyone have any ideas what may have caused this?

Thanks
 

·
Premium Member
Joined
·
288 Posts
I can't say what cause this, but it has happened to me. Twice actually. All I did was shut the stereo off, shut the truck off, waited 5 minutes, then turned it back on. That happened almost 2 years ago, just a weird thing that happened. If that doesn't help, I'm not too sure. Hope this helps though
 

·
Registered
Joined
·
2,095 Posts
I can't say what cause this, but it has happened to me. Twice actually. All I did was shut the stereo off, shut the truck off, waited 5 minutes, then turned it back on. That happened almost 2 years ago, just a weird thing that happened. If that doesn't help, I'm not too sure. Hope this helps though
PUNCH IT !! Just kidding dont do that lol...that sucks bro :( just more of an excuses to get a new deck :)
Hope everything works out for you
 

·
Registered
Joined
·
247 Posts
Discussion Starter · #4 ·
Disconnected & reconnected the battery and it's working again :)
 

·
Registered
Joined
·
2 Posts
My radio just decided to shutdown one day and hasn't worked to this day. I have had enough of this truck! New Engine, rear differential change out, calipers now this! Oh yeah, blower motor doesn't work, air bag light is on. I AM AT WITTS END....... HELP....... PLEASE!!!!!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top