Nissan Titan Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter #1
So got my truck hand washed today, started up fine, put it in drive, slowly pressed the gas cuz i didnt want sling from the tires everywhere.....nothin...dead....hhhmmmm ok weird.

starts up fine and carry on my way, about 2 miles down the rode my truck hesitates like it was dying, had my stereo up so i dont now what it exactly did, did that for like 1 sec than was normal.....

Great too cuz im about to drive 4 hours away in about an hour sooooo yeah.

my dash lights are still on because i never topped off my brake fluid...that shouldnt have any thing to do with it......

any imput?
 

·
Registered
Joined
·
910 Posts
Did you wash the engine compartment at all?
 

·
Creator of the DUMBEST thread ever!
Joined
·
4,107 Posts
Water touching the both positive and negative terminals on your battery, caused a huge ark, that melted your ecu to your sheet metal (and probably your fuse box as well). That would have been the smell you left out of your description of the problem... basically your truck is a paper weight, without 4,000 in repairs. Good Luck.
 

·
Registered
Joined
·
45 Posts
I don't know about the huge ark, but I'm not the best at figuring out those kinds of problems. I know that sometimes the battery can interfere w/ gas on an electronic throttle if it is weak. My wifes Murano had an issue like that. It would crank and run, but touch the gas and it wouldn't move. In the end the alternator was faulty on it (recall issue) which killed the battery.
 

·
Registered
Joined
·
88 Posts
I had the same thing happen to my '98 Fronty after washing the engine compartment. Turned out the alternator cover let water in. Hopefully it's something that simple and not the nightmare King described.
 

·
Premium Member
Joined
·
6,584 Posts
Check to see if the air filter is wet. If so, the MAF sensor could get wet, and cause the problem.
 

·
Registered
Joined
·
423 Posts
Start small, look at the simple little things first.
I've never heard of anything like king described happening. Not saying that it couldn't but sounds more like a freak accident, I'm no mechanic but have spent a decent amount of time wrenching. GL
 

·
Creator of the DUMBEST thread ever!
Joined
·
4,107 Posts
just in case anyone was wondering, my post was 100% sarcastic. Hope you find the problem.
 

·
Registered
Joined
·
1,054 Posts
this happened to me when i washed my wifes old corolla. it would idle really ruff and would try and stall out on me when accelrating. i new somthing was wet so i just drove it till it cleared up. just keep it runing it will clear right up in about hour.
 

·
Registered
Joined
·
45 Posts
KINGMADE said:
just in case anyone was wondering, my post was 100% sarcastic. Hope you find the problem.
People who believe your original post probably believe the media is reporting the facts too.

:auslachen2-big:
 
1 - 14 of 14 Posts
Top