Nissan Titan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I backed my truck out of the garage the other night, shut it off, and now it won't crank. It just clicks when I turn the key.
In prior weeks I have had similar issues where when in Park it would do the same thing. So, I would shift to Neutral and it would start.
Now it won't start in either location. It just clicks.

Anyone know what to troubleshoot?
Could it be the starter, neutral switch, or resistor somewhere?

It's a 2005 Titan with over 200,000 miles on it. It's been REALLY good to me up to this point.
However, I don't want to spent a ton since the truck is not worth a ton. However, it's been running and riding great. Just won't start.

Any help would be GREATLY appreciated.

Thanks.
 

·
Registered
Joined
·
2 Posts
I backed my truck out of the garage the other night, shut it off, and now it won't crank. It just clicks when I turn the key.
In prior weeks I have had similar issues where when in Park it would do the same thing. So, I would shift to Neutral and it would start.
Now it won't start in either location. It just clicks.

Anyone know what to troubleshoot?
Could it be the starter, neutral switch, or resistor somewhere?

It's a 2005 Titan with over 200,000 miles on it. It's been REALLY good to me up to this point.
However, I don't want to spent a ton since the truck is not worth a ton. However, it's been running and riding great. Just won't start.

Any help would be GREATLY appreciated.

Thanks.
My 2007 did the same thing.Turned out to be the starter. Its under the plenum.
 

·
Registered
Joined
·
5 Posts
I think from what are you telling it might be the starter, and better go to a service to repair it because home it's very hard and you must know how to do it very well or you might break it harder or something else. I remember that when I got recruited by avatarfleet.com it was because I am a daily driver and worked as a mechanic for 5 years before, and that's why I know very well how to repair or change some pieces of the truck with no problem, just need some tools and a well-prepared garage.
 

·
Registered
Joined
·
11 Posts
I backed my truck out of the garage the other night, shut it off, and now it won't crank. It just clicks when I turn the key.
In prior weeks I have had similar issues where when in Park it would do the same thing. So, I would shift to Neutral and it would start.
Now it won't start in either location. It just clicks.

Anyone know what to troubleshoot?
Could it be the starter, neutral switch, or resistor somewhere?

It's a 2005 Titan with over 200,000 miles on it. It's been REALLY good to me up to this point.
However, I don't want to spent a ton since the truck is not worth a ton. However, it's been running and riding great. Just won't start.

Any help would be GREATLY appreciated.

Thanks.
Try turning key from run to start several times. If starter finally engages, it's the starter. I have a 2006 that I nursed along for well over a year with this problem. Sometimes having to switch from run to start 10 times. Actually this is caused mainly by the starter solenoid which is on the starter, under the intake manifold. Look on uTube for some thorough instructions. I replaced mine at 63 years old, (me not truck) took about 3 hours. Good luck.
 
1 - 4 of 4 Posts
Top